1. Auctionator uses GetAll scan to get all items on AH with a single request. It has never worked on Warmane or Molten. Instead it returns only first page. It's a known issue but I don't know if it's reported on bug tracker and if it's just broken or disabled intentionally.

  2. Auction House GetAll Scan Issue

    Interesting bug of the Auction House that breaks Auctionator addon. I just filled a report in the bugtracker, hopefully they fix it soon. Please, vote it up!

  3. May 22, 2018  
    Tried the wotlk fix. Still doesn't list sold auctions in Beancounter. I'm using Auctioneer version for 3.3.5. What version should I use? Maybe 4.0.1?

  4. May 22, 2018  
    I am using Auctioneer Suite 5.8.4723, which is for patch 3.3.3. It's still working for me. It will only work for auctions you sell after you start using the addon. And it might not work if your WoW client is not in English.

  5. May 22, 2018  
    My client is in English. It still didn't work with your addon. Even with 4.0.1 version (english client). Guess I'll have to try 3.3.3 version. Weird though, because it records SOME sales (but not very many at all).

    EDIT: Now with 3.3.3 beancounter tab doesn't even show up in the AH.
    Edited: May 22, 2018

  6. May 22, 2018  
    As far as I know, there is no Auctioner Suite version for 3.3.5. There are only versions for 3.3.3 and 4.0.1. And both should work with my addon. Check sender names of your AH mails. If sender name is Alliance Auction House or Horde Auction House, everything should be working correctly. But as I said, auctions sold before you started using my addon won't show up.
    Edited: May 22, 2018

  7. May 22, 2018  
    I remember some mails being sent with the name of the city, like "Darnassus Auction House"

  8. May 22, 2018  
    As far as I know, there is no Auctioner Suite version for 3.3.5. There are only versions for 3.3.3 and 4.0.1. And both should work with my addon. Check sender names of your AH mails. If sender name is Alliance Auction House or Horde Auction House, everything should be working correctly. But as I said, auctions sold before you started using my addon won't show up.
    You are right, I'm using 3.3.3 version not 3.3.5. However it does show up as "Alliance Auction House ". Still doesnt list in beancounter. How can I do a clean install of beancounter? i.e. what must I delete to ensure it should work? I'd rather avoid deleting my whole WTF folder xD

    Also, does your addon need to be renamed? Or literally just put it into the addons folder? Although if it is saying Alliance Auction House it means it worked right?

    Thanks for your patience :D

  9. May 22, 2018  
    I remember some mails being sent with the name of the city, like "Darnassus Auction House"
    That's what this addon fixes. It renames all of them to Horde/Alliance Auction House.

    You are right, I'm using 3.3.3 version not 3.3.5. However it does show up as "Alliance Auction House ". Still doesnt list in beancounter. How can I do a clean install of beancounter? i.e. what must I delete to ensure it should work? I'd rather avoid deleting my whole WTF folder xD

    Also, does your addon need to be renamed? Or literally just put it into the addons folder? Although if it is saying Alliance Auction House it means it worked right?

    Thanks for your patience :D
    It's just a regular addon. You have to put it in addons folder, just like any other addon. If mails show up as Alliance Auction House, it should be working. If it's working, you will see a message in chat first time you open AH or mailbox.

    Beancounter addons data is stored here:
    WTF\Account\<Account name>\SavedVariables\BeanCounter.lua

    But I don't think deleting it will fix anything.

  10. 4 Days Ago  
    Hi

    Could you please upload your exactly Auctioneer and AH fix zip files?

    My beancounter still doesn't work. I have the same problem as described here. The sold auctions are not logged. Although some are. I can't tell if the issue is linked to the name of auctions or not. I think that's not the problem. I even tried to modify the code in the beam counter to temporary read all the emails but it didn't help.

    FYI Here is the video https://youtu.be/EZnnEyatSKw

    Thanks a lot :)
    Edited: 4 Days Ago Reason: Add video

  11. 4 Days Ago  
    I am using Auctioneer Suite 5.8.4723 and from looking at BeanCounter on my chars I didn't notice anything wrong but I can't guarantee that nothing is missing. What version are you using and which auction house are you using to sell the items? I will try to do some more testing later.

    https://wow.curseforge.com/projects/...r/files/427823
    Edited: 4 Days Ago

  12. 3 Days Ago  
    So what I did:

    - Deleted all plugins, download the version you linked and the FIX for warmane
    - Deleted all beam data from WTF folder under my player

    Got 3 new sells from Auciton . Pick up the mail - it says scanning 2/3. Than it's gone.
    When I got to the auction I saw only 1 item: https://imgur.com/a/xv3vSi1

    When I open the DB I can see the mails but only 1 item is in completed Auctions:

    [code]
    ["completedAuctions"] = {
    ["6359"] = {
    ["item:6359:0:0:0:0:0:0:0:80"] = {
    "1;555;100;23;478;439;Tabletom;1534522976;;A", -- [1]
    },
    },
    },
    ["wealth"] = 1147935,
    ["postedAuctions"] = {
    },
    ["completedBidsBuyoutsNeutral"] = {
    },
    ["vendorbuy"] = {
    },
    ["failedAuctions"] = {
    },
    ["failedBids"] = {
    },
    ["failedBidsNeutral"] = {
    },
    ["version"] = 2.12,
    ["faction"] = "Alliance",
    ["completedBidsBuyouts"] = {
    },
    ["failedAuctionsNeutral"] = {
    },
    ["completedAuctionsNeutral"] = {
    },
    ["mailbox"] = {
    {
    ["read"] = 1,
    ["sender"] = "Alliance Auction House",
    ["time"] = 29.99937438964844,
    ["subject"] = "Auction successful: Firefin Snapper",
    }, -- [1]
    {
    ["read"] = 1,
    ["sender"] = "Alliance Auction House",
    ["time"] = 29.98039436340332,
    ["subject"] = "Auction successful: Green Hills of Stranglethorn - Page 18",
    }, -- [2]
    {
    ["read"] = 1,
    ["sender"] = "Alliance Auction House",
    ["time"] = 29.96050834655762,
    ["subject"] = "Auction successful: Plans: Shadow Crescent Axe",
    }, -- [3]
    [code]

    Here is the full DB file https://pastebin.com/upzDbb8X

    Btw I am selling on the Stormwind Auction. Based on the mailbox text from the DB I think there is no problem with the fix.
    I am playing on Lordeon
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Hm but maybe I sold only the first item why this new plugin / DB was active. Does it not track the old auctions only based on the mail?
    Maybe it's working now? With your version? Let's see.

  13. 3 Days Ago  
    Btw I am selling on the Stormwind Auction. Based on the mailbox text from the DB I think there is no problem with the fix.
    I am playing on Lordeon
    That part seems fine. So far the only differences are that I play on Icecrown and use Ironforge auction house, which already has correct sender name. But with the fix, it should not matter.

    Hm but maybe I sold only the first item why this new plugin / DB was active. Does it not track the old auctions only based on the mail?
    Maybe it's working now? With your version? Let's see.
    I am not sure how exactly BeanCounter works. If it hasn't fixed your issue, post here and I will check if I can find what causes it. Currently the only thing that looked suspicious to me is always having 00:00 delivery time in sale pending mails but I don't know if it actually affects anything.

  14. 3 Days Ago  
    So it's working now. To get it working you need:

    https://wow.curseforge.com/projects/...r/files/427823
    And the Warmane AH fix.

    The item has to be sold using the auctioneer plugin. If you sold some items without it won't track. So you have to sold it with the plugin and get the email while the plugin is active.

    Thanks for the help :)

First ... 789

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •