1. Download

    I am happy to bring you a Cataclysm 4.3.4 launcher for Macs.

    1. Download the World of Warcraft - Cataclysm installer
    2. Unzip the file
    3. Open the World of Warcraft - Cataclysm folder
    4. Do not click on the launcher. Instead, right click the World of Warcraft icon
    5. Select "Show Package Contents"
    6. Navigation into Contents/MacOS
    7. Click on the World of Warcraft file inside that folder and wait for the game to launch

    If you are on Apple's latest OS, you might have some issues running the launcher by just clicking the launcher icon. If this is the case, unzip a fresh copy of the folder and follow the directions above to navigate to the Unix file inside the Package Contents.

  2. There is no 'unix' file inside the package contents... T.T

  3. This launcher doesn't work for me... can you post the old version? I had it working before but no matter what I do this one crashes after launching the unix executable.

  4. May 2, 2016  
    Get back the old launcher! cannot this thing do not work

  5. May 2, 2016  
    Humm yeah nobody cares I guess... mac players not able to get on their cata account anymore... GM told me in ticket basically "/shrug cant help you diagnose it yourself on google" –– this launcher wont work at all and nobody will post old one. Moreover Warmane should supply official launcher because anyone could post a program here that contained some virus or malware and then basically warmane is distributing viruses

  6. May 4, 2016  
    this is not working m8, can you fix it again?

  7. July 5, 2016  
    Any chance to get a cluent in Mac 4.3.4 cataclysm ?

  8. You have to change the .app into .dmg, run it, then change back, works

  9. for those on Sierra who are unable to get the game launching, this is how i got it to work: After right clicking and showing package contents, and navigating to Contents -> MacOS - Double clicking this file does nothing, simply open terminal, drag the file to terminal, it will put in the path - hit enter and voila!

  10. Hi,

    I'm a returning player but I only have MacOS Sierra. In this private server, I only played in Cataclysm but I can't find a working version for Mac. I know probably no one cares but I used to donate and care a lot for this server.

  11. Yeah i tried all of the ways suggested and im on El capitan and still nothing is working... would love some help... lmao

  12. Just wanted to say I've got this working perfectly on macOS 10.12.4. I had to drop the WoW file in " World of Warcraft.app/Contents/MacOS/En" into terminal and hit enter, but it works fine. Thanks

  13. i tranfered files from my windows computer and downloaded wine bottle to open the file /read ... but now i want to gt cata .. if i download from warmane how do i go about inserting files into other and all that good junk to be about to play? btw im new to all this lol

  14. Im on 10.13.1 version of Sierra and i tried all methods listed above( A little guidance would be very helpful

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts