1. 6 Days Ago  

    Never seen anything like this and its getting worse

    Been playing for years now atm playing Rogue and the "Lag" of individual players or "random" teleportation seems sketchy. I understand that if the server lags we all lag, also that some players have high MS.....but it was never this bad far as i can remember. I would even go so far that some people now how to create High Latency by bugging out or whatever....i cant remember how many times i had to stand on the player or be slightly behind him in order to dps or cc. Not sure what happend, but the way it is now definitly isnt working.

  2. 6 Days Ago  
    It's not only people randomly starting to teleport, especially in arena, but what happened yesterday to me was, I was in 2s with my partner and he suddenly got disconnected, at first he couldn't even log because login server was down for some reason and after trying couple times he made it in, although when he came online he was back in the arena but he appeared to me as an enemy and I also appeared to him as an enemy, which prevented me from healing him and that caused him to die and we lost the arena. I was okay because an hour later there was a server shutdown for fixes and I thought that bug would get fixed, but unfortunately it didn't as it happened again in the late evening. This time though both my partner and one of the players of the enemy team got disconnected. So both of them couldn't login for about 20 mins. Restarting wow and deleting Cache folder didn't help, it was just login server down. This really has to be fixed asap because it'd become one of the biggest gamebreakers.

  3. 6 Days Ago  
    "i cant remember how many times i had to stand on the player or be slightly behind him in order to dps or cc."
    Yeah...
    https://imgur.com/a/kXD11

    Third pic is also one big wtf, i just stood in front of SW for some time and all of the sudden i started to lose hp so i used Ice Block and than i've noticed breath bar on top of my screen, lol.

    ... Also, im not sure what's going on with the new "anit-cheat" or w/e that is, but playing my monk is kinda impossible when i'm gettin teleported back half of the time when i use Roll or Flying Serpent Kick, it also happens when i use nitro boost or any other speed buff really ...

  4. 1 Day Ago  
    Been playing for years now atm playing Rogue and the "Lag" of individual players or "random" teleportation seems sketchy. I understand that if the server lags we all lag, also that some players have high MS.....but it was never this bad far as i can remember. I would even go so far that some people now how to create High Latency by bugging out or whatever....i cant remember how many times i had to stand on the player or be slightly behind him in order to dps or cc. Not sure what happend, but the way it is now definitly isnt working.
    Glad that you brought this up. I can confirmed that this is really happening. So many wierd **** going on. Aside from players randomly teleporting, this has been happening as well during battlegrounds on those Demolishers. One of those instance is in Strands of the Ancients. We've managed to defend all exterior gates and have camped the enemy in their graveyard. We had couple of minutes left before the battleground ends. However, all of a sudden, we've got a message that says that the exteriror gates have been attacked. We rushed to those gates but failed to defend it as it was got destroyed like in a few seconds only (WTF?!). We chased the demolisher going to the second gate but noticed something odd. This demo is ****ing teleporting! I thought i was just having some latency issues or something like that but the rest of the raid seem to have noticed the unusual as well. Not long enough, another Demo joined in and was doing the same thing. We were unable to catch up with them anymore and the relic was breached. Definitely, that was a sure win for us, but hey, **** happens. Another instance was in Arathi Basin. This just happened recently. We've defended 3 flags and had a resource score of 1490/1600, while the enemy had 2 flags at 1290/1600. But then again **** happens. Everyone in our raid started lagging. The raid chat seems to be okay as we can see each responses immediately, but our characters are not. I had the target enemy infront of me but it kept on saying that the target is out of range. We still managed to play until the end but unfortunately the enemy had taken the lead and we didn't catch up anymore.

  5. 1 Day Ago  
    One of those instance is in Strands of the Ancients.
    Was this SOTA incident about 12-13 hours ago ?

  6. 21 hours ago  
    Was this SOTA incident about 12-13 hours ago ?
    No. This happened last week.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •