1. 2 Weeks Ago  

    ISboxer for Warmane Outland

    Hey!
    I just came back over to the server (from retail) and I was wondering if anyone can help me regarding ISboxer..
    I have the newest version of it (paid for), and this wont let me pick the right version of wow

    Does anyone know how to fix this? I've tried adding it as a new game, but it still wont let me choose it

  2. 1 Week Ago  
    im looking into it, try an older version of isboxer like 40? i really need to know isboxer supports older version before i buy it aswell....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •