1. Shield keeps disappearing from macro - Warrior

    Hello! Does anyone know why the macro will not stick for me? I have to press it once to see the shield automatically become unequipped, then press it again for it to come back on.

    It's quite inconvenient, there must be a fix to this or even possibly a conflict with an addon. Thanks for any help.

  2. I do, it is

    /cast Defensive Stance
    /equipslot 16 Wrathful Gladiator's Handaxe
    /equipslot 17 Icecrown Glacial Wall

  3. Wrathful Gladiator's Handaxe - Nice!!

    Now walk me trough this, you click the Macro and it:
    1) Puts you in defensive stance
    2) Equips 1h Axe
    3) Equips sheild

    Are you sure that these items are in the correct slots?
    bag[16] (Wrathful Gladiator's Handaxe)
    bag[17] (Icecrown Glacial Wall)

    Could these be mixed up? (sheild won't equip before weapon)

    If you press it again after equipping the items, the shield and sword won't be in the bag slots, they will be on your character.

    TBH this Macro looks like more hassle than it's worth!! :P

  4. #showtooltip
    /cast Defensive Stance
    /equip Wrathful Gladiator's Handaxe |or use the alternative below
    /equip Icerown Glacial Wall

    /equipslot 16 Wrathful Gladiator's Handaxe

  5. Still not working. Seriously don't understand what's going on here. #showtooltip is also in the macro.

    Entire macro is:

    /cast Defensive Stance
    /equipslot 16 Wrathful Gladiator's Handaxe
    /equipslot 17 Icecrown Glacial Wall

  6. Nevermind. Found out it was a conflcit with my Outfitter addon.

  7. I was gonna say, yeah outfitter fails with those kinds of macros.

  8. Damn I had same problem my addons got reset somehow and my shield aso got unequiped nice post man fixed it for me as well :)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts