1. Is Archaeology broken?

    I'm coming back after a year plus hiatus and have several toons with 500+ Arch, when I survey and find the object and go to loot it, the loot window doesn't pop up and the item dissapears.
    It used to work fine, and I've tried with different toons and different accounts, same.
    Can someone confirm it is or isn't working?
    If isn't, why?! It was working fine!!

  2. wow cool been broken for along time,thanks

  3. wow cool been broken for along time,thanks
    Yeah i can see, https://www.warmane.com/bugtracker/report/86457 is the report.
    To keep it short everything that has been reported so far regarding Archaeology has been reviewed and added to that report

  4. So after posting this, loot windows did start opening but were empty...except! Once in Swamp of Sorrows I got fragments once on a dig.
    After that one loot, I tried for probably a couple of hours all over but nothing but empty loots.

  5. Just tried, loot windows open, but empty...

  6. It has not been fixed yet, ill let you know when the fixes are live and what has been corrected.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts