1. 3 Days Ago  

    Frame Drop

    Does anybody experience frame drop? Im running ultra mode and before its not dropping.

    This is my rig
    Ryzen 5 3400g
    GTX 1050ti 4gb
    16gb ram
    M.2 SSD

    Anyone can help?

  2. 3 Days Ago  
    Does anybody experience frame drop? Im running ultra mode and before its not dropping.

    This is my rig
    Ryzen 5 3400g
    GTX 1050ti 4gb
    16gb ram
    M.2 SSD

    Anyone can help?
    Is it happening in Dalaran?

  3. 3 Days Ago  
    Is it happening in Dalaran?
    No, im in Stranglethorn Vale

  4. 3 Days Ago  
    No, im in Stranglethorn Vale
    Only in specific area of STV or the whole map?

  5. 3 Days Ago  
    Only in specific area of STV or the whole map?
    Everywhere

  6. 3 Days Ago  
    When did it start happening?
    Try playing around with GPU settings. WotLK is an old app and can't really utilize all you've got in your PC.
    Edited: 3 Days Ago

  7. 3 Days Ago  
    Im not really sure, I just noticed it recently. I thought it was just my internet connection.

  8. 3 Days Ago  
    Plenty of suggestions here: http://forum.warmane.com/showthread.php?t=390882
    Might wanna try some of them. Read the whole post.

  9. 3 Days Ago  

  10. 3 Days Ago  
    I'm having the same problems today with a 1060, I think it may be the new nvidia drivers? Did you install those too.

  11. 3 Days Ago  
    Yeah I did, maybe thats the reason hmm..

  12. 2 Days Ago  
    also having the same issue after the driver update
    game is not playable

  13. 2 Days Ago  
    also having the same issue after the driver update
    game is not playable
    Menu > video > disable "hardware cursor"

  14. 1 Day Ago  
    Menu > video > disable "hardware cursor"
    I can make no sense as to "WHY" but this seems to do something to improve it, so thanks a bunch!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •