1. 1 Week Ago  
    I'm from Sweden using Comhem too and also have this issue. Yesterday it worked fine.

  2. 1 Week Ago  
    Yeah I use ComHem too. I tried with a VPN now and that worked, so seems like there is some issue with ComHem.

  3. 1 Week Ago  
    Same problem here. I don't want to pay for VPN. I rather play retail WOW then. I play warmane because it's free to play. Not everyone is rich and have money for VPN. I hope they fix it soon.

  4. 1 Week Ago  

  5. 1 Week Ago  
    Same issue, stuck at realm selection

  6. 1 Week Ago  
    New Zealand, same issue. neighbour can log in but i cant.

  7. 1 Week Ago  
    Yeah... im NZL aswell and same issue, cant log into game server

  8. 1 Week Ago  

  9. 1 Week Ago  
    I think east Asia and Oceanic regions are effected by this.

  10. 1 Week Ago  

  11. 1 Week Ago  
    Same here . It's Fixed. I'm able to login now.

  12. 1 Week Ago  

First 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •