1. Play Warmane WOTLK 3.3.5 on macOS 12+,64bit (Hackintosh/external GPUs included)

    (Mods, I posted the first guide in the wrong section. This is the right guide I want posted in the correct section..sorry)
    Too long didn’t read:
    Go to the Installing header below

    This guide is for anyone who uses a Mac with OS12+ or Mac 64bit having graphic problems spastically in game and you have tried Crossover, Wine standalone, and Wineskin with no success. This also works for anyone who is using a Hackintosh with an external GPU.
    • This method does not use parallels/VMs. This works by using Porting Kit(freeware). Porting Kit utilizes Wine through Wineskin winery with their own added quirks and fixes.
    • This may or may not work for you. If you have been having similar issues running wotlk 3.3.5 on your Mac 64bit, give this a shot and let us know how it goes for you.
    • I tried EVERYTHING (do not underestimate that statement) to fix my graphic problems with my Hackintosh(Mac) and this was the only method that surprisingly worked 100%

    The problem and the fix:
    Spoiler: Show
    • This method fixes any graphic glitches in all major cities like Shattrath, Dalaran, etc. and allows you to actually use the working visual settings meter 100%.
    • The glitches are due to shaders not being processed correctly with glsl on the latest versions of crossover, wine standalone, and wineskinery via homebrew or GitHub.
    • After some research this is due to some wrappers/engines missing necessary libraries. You can observe the errors through Wine’s console.
    • The problem manifest itself as psychedelic rays of colors coming from your character or other models in game.
    • These textures appear randomly and dance spastically in areas such as Shattrath & Northrend and can not be worked around by adjusting the settings because shader driver is actually not even working correctly in those instances.
      Example of shader/texture glitches and related Wine debug logs (right click and view in new tab for full image):
      Spoiler: Show

      Wine Debug log showing error:

    • This method also seems to improve performance comparable to native wotlk 3.3.5. I was able to see 120+ fps on high settings in most areas in the game. I’ve generally seen an average of 50-60+ fps increase.

    Installing(applying the fix):
    Spoiler: Show

    Watch and follow the youtube instructional video here:
    Youtube Instructional Video

    1. Download latest version of Porting Kit for Mac
    2. Click on “New Custom Port” from the main screen
    3. Name the bottle/prefix that will be created anything you want
    4. Now configure the Prefix.
    5. For the engine choose: “WS11WineCX19.0.2-3” OR “WS11WineCX19.0.2-3 64bit”
    6. For the Window driver choose: “Mac Driver” unless you are on osx11 and have problems try choosing “xQuartz”
    7. Click Next twice and choose to install when are ready. A window will appear for you to select the “installer”
    8. Navigate to the root of your wow game folder and select the “wow.exe” and press open
    9. It will create the prefix, install all necessary libraries, and configure the prefix for first start
    10. Wow will open during this process, close it.
    11. Next the installation will show a window for you to choose the same “wow.exe” again and choose open
    12. Installation will complete successfully
    13. Nothing else is required. This works the same as Wineskin winery since it is based off of it.
    14. You can access the winery menu from porting kit or in finder at the location of the application.
    15. Everything will work as it is supposed to. You can configure your graphic settings in game or within the config files in the WTF folder.
    16. All graphic settings were observed to work appropriately in many areas of the game

    Spoiler: Show
    I tried this with the Warmane default client and the wotlk HD client found in the forums. Works the same.
    I attempted to run the game using DXVK by interfacing through D3D9, but could not get accelerated graphics using the method I was trying. I will update this thread if I get it to work successfully.

    My configuration:
    I am using a custom Multiboot build with a Hackintosh OS using smbios iMacPro1,1. CPU: i7 11700k OC @ 4.9ghz, GPU: AMD 6600XT 8GB. My Hackintosh EFI configurations are stable and everything works.

    Game Visual Settings: high settings
    Playtime during recent test: 5 hours non-stop
    Refresh rate in config file: 144hz
    gxApi in config file: D3D9 (left untouched)

    Areas tested ( I will continue to update this):
    (I went to the most commuted areas on the map in terms of questing)
    Azeroth - Traveled most of Azeroth by mount and found no glitches or errors in the wine prefix console
    Outland - Traveled most of Outland by mount and found no glitches or errors in the wine prefix console

    Utgarde Keep - working, no errors

    Major Cities I personally tested:
    Orgimar - working, no errors
    Shattrath - working, no errors
    Undercity - working, no errors
    Howling fjord - working, no errors
    Warsong/Borean Tundra - working, no errors

    I hope this helps someone out.
    Edited: December 15, 2022

  2. I used this method. The 2020 MAC PRO does not have a separate GPU. It has an external EGPU, but the EGPU fan does not work. It seems that the EGPU is not used

  3. I used this method. The 2020 MAC PRO does not have a separate GPU. It has an external EGPU, but the EGPU fan does not work. It seems that the EGPU is not used
    Just to be more clear on my end I am using a hackintosh system that replicates smbios(different Mac products). My setup can be a little different from the regular mac user. When I said "external GPU" I meant any GPU connected to a PCIE slot on the motherboard, but if I understand correctly the external GPU doc on a native Mac machine use PCIE so it should work the same.

    Sometimes depending on your GPU, the fans will never turn on. For example, my Windows partition uses an Aorus 3060TI, my fans will rarely turn on when playing WoW on high settings. Just something to consider.

    To check if WoW is actually using the GPU, Run WoW, login, briefly run around in the realm, and then open activity manager and click "window" at the top menu bar and select "GPU history". Check to see if you see your external GPU is in that list while running the game and if you see any activity from it.

    If not try adding the following to your config file:
    Spoiler: Show
    add this declaration without the asterisks:
    * SET gxApi "opengl" *
    Save it. After saving, right click on the config files and click info, change the permissions to read only across all users.
    as an alternative fix attempt, you can also try the experimental d3d9 driver by adding this declaration without the asterisk:
    * SET gxApi "D3D9EX" *
    Save it. After saving, right click on the config files and click info, change the permissions to read only across all users.
    As a second alternative you can also try to specifically declare d3d9 in the config file even though it set to be used by default:
    * SET gxApi "D3D9" *
    Only use one of these declarations. If the game does not have valid configurations it will result to the default backup config.

    Repeat the step of using activity manager to verify the GPU's acitivty.

    I have read some native mac users have had success by using opengl directly.

    Let me know if this helps or if it doesn't.
    Edited: November 23, 2022

  4. hi, jayraza22:

    Thank you for your suggestions and add that my MAC computer model: 13 inch, 2020, Four Thunderbolt 3 ports, external EGPU AMD RX 6600XT

    I checked my activity manager and found a program called "wine32on64 reload" in my EGPU process. Does this mean that WOW has been running in the EGPU? Although the EGPU fan is still not running (the highest special effect has been opened in the main city), my CPU fan is running. This is really strange. In addition, I found some interesting things in the process of trying:

    1. You must use the "WS11WineCX19.0.2-3" version of wine. If you use a higher version, the screen will have problems. I did not try this change in Wineskin.
    2. The SET gxApi "opengl" parameter cannot run the program normally Both SET gxApi "D3D9EX" and SET gxApi "D3D9" can run the program normally

    Finally, when the porting kit opens the program, a command line window will appear. How can I prevent it from displaying when it starts? thank you

  5. Awesome, I am glad that works. That is correct about the wine versions. Only both WineCX19.0.2-3/64bit works to my knowledge.

    The only way I know how to make the command prompt go away is to move the game folder within the prefix "program files" OR "program files x86" > warmane folder. You can access the prefix by right clicking on the wow/warmane game icon and selecting "show package content" you will see the "c" drive. Access the c drive and you will see the program files/x86 folder. Move your game folder into this location.

    Once that is done, close that finder window and go back to the game icon you use to run/access the prefix. Right click again and "show package content" and select the "wineskin" package and run it. Select "advanced" and where you see "Windows EXE" click "browse" look for and select the wow.exe in the game folder we just moved into the prefix. By default winery will have you within the prefix root so you should already see the program files packages.

    After you select the wow.exe and verified it's path is used you can close this window. Reopen wineskin to verify the path you selected once more.

    Now it will run without the command prompt. There may be another way of doing it but at the moment I am unsure.
    Edited: December 15, 2022

  6. Screen freezing

    Hey Jayraza22, thank you for putting all of this together!

    Although the visual/graphic bug has been fixed by this solution, there is a different, new problem.
    My entire screen freezes for multiple seconds, sometimes few times a minute, depending on what I am doing.
    Please, is there any fix for this issue that you know of?


  7. Lagging And Freezing The Screen.

    Dropping FPS constantly. And also freezes the screen, also has a separate GPU but it is not working. What do you think about this?? I think there must be an issue with resolutions. Want to fix this problem then everything will be okay to play. Thank you.

  8. 4 Days Ago  
    Hi, i follow step by step on my mac pro m2 and didn't work. Any help for this? Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts